re = /^(?=.*[a-zA-Z])(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=(?:[^!"#\$%&'\(\)\*\+,-\.\/:;<=>\?@\[\]\^_`\{\|\}~]*[!"#\$%&'\(\)\*\+,-\.\/:;<=>\?@\[\]\^_`\{\|\}~]){1}).*$/
str = 'qWertyt3est@com
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end