re = /^(?=.*?[A-Z])(?=.*?[a-z])(?=.*?[0-9])[a-zA-Z0-9]{6,15}$/m
str = '1aA123
1aA123!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end