const regex = /^\$(Now|Today|CurrentMonth)\s*(?:([+-])\s*(\d+)([dhm]))?\s*$/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\$(Now|Today|CurrentMonth)\\s*(?:([+-])\\s*(\\d+)([dhm]))?\\s*$', 'gim')
const str = `\$Now
\$Today
\$CurrentMonth
\$Now + 2h
\$Now - 4m
\$Now + 6d
\$Today - 7d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}