#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[(?:http://|https://)*(?:\w+\.)*(\w+(?:\.(?:com|org|net|edu|gov|info|biz|io|co|app|co|uk|de|jp|ca|dev|app|gg))+)]\((?:http://|https://)(?:\w+\.)+\w+(?:/\w+)*\)"
Local $sString = "Normal links don't get caught:" & @CRLF & _
"[do not catch this](https://example.com)" & @CRLF & _
"orthis.com" & @CRLF & _
"" & @CRLF & _
"Neither do links with full stops in the message:" & @CRLF & _
"(messages. with. full stops)[https://example.com]" & @CRLF & _
"" & @CRLF & _
"even if they forget a space" & @CRLF & _
"[whoops.nospace](https://example.com)" & @CRLF & _
"" & @CRLF & _
"because we catch based on tld:" & @CRLF & _
"[catchthis.com](https://malicious.link)" & @CRLF & _
"[catchthis.org](https://malicious.link)" & @CRLF & _
"[catchthis.net](https://malicious.link)" & @CRLF & _
"[catchthis.edu](https://malicious.link)" & @CRLF & _
"[catchthis.gov](https://malicious.link)" & @CRLF & _
"[catchthis.info](https://malicious.link)" & @CRLF & _
"[catchthis.biz](https://malicious.link)" & @CRLF & _
"[catchthis.io](https://malicious.link)" & @CRLF & _
"[catchthis.co](https://malicious.link)" & @CRLF & _
"[catchthis.uk](https://malicious.link)" & @CRLF & _
"[catchthis.de](https://malicious.link)" & @CRLF & _
"[catchthis.jp](https://malicious.link)" & @CRLF & _
"" & @CRLF & _
"[www.catchthis.com](https://malicious.link)" & @CRLF & _
"[https://catchthis.com](https://malicious.link)" & @CRLF & _
"[http://catchthis.com](http://malicious.link)" & @CRLF & _
"" & @CRLF & _
"any combination of the above also gets matched for multiple tld urls:" & @CRLF & _
"[link.co.jp.org.net](https://malicious.link)" & @CRLF & _
"" & @CRLF & _
"This is perfect because we can block any malicious link with any tld or any number of subdomains, but have a controlled list of tlds that links with a fake url begin with. Since most non-standard tlds are sketchy, we don't even need that many:" & @CRLF & _
"" & @CRLF & _
"[link.com](http://any.malicious.li.nk/anything/at/all)" & @CRLF & _
"" & @CRLF & _
"Any number of subdomains also get caught:" & @CRLF & _
"[auth.google.com](https://malicious.website.com)" & @CRLF & _
"[any.number.at.all.com](https://malicious.link)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"This method of having a set tld list means almost zero false positives, with the drawback of people having to recognise sketchy urls themselves:" & @CRLF & _
"" & @CRLF & _
"[linkwitha.sketchytld](https://malicious.link) // not caught" & @CRLF & _
"" & @CRLF & _
"If you want a wider net with a higher chance of false positives, replace the subdomains with the word matcher wildcard (\w+):" & @CRLF & _
"" & @CRLF & _
"\[(?:\w+\.)*(\w+(?:\.(?:\w+))+)]\((?:http://|https://)(?:\w+\.)+\w+(?:/\w+)*\)" & @CRLF & _
"" & @CRLF & _
"Or a much shorter one that doesn't catch http:// links but that is short enough for Discord: [discord already blocks "fake" links with https in the title but not ones without it]" & @CRLF & _
"" & @CRLF & _
"\[(\w+\.?)*]\((https?://)(\w+\.?)*\)" & @CRLF & _
"" & @CRLF & _
"a longer method with subdomain denylisting is also short enough for Discord:" & @CRLF & _
"" & @CRLF & _
"\[(?:(?:www|auth|login)\.)*(\w+(?:\.(?:com|org|net|edu|gov|info|biz|io|co|app|co|uk|de|jp|ca|dev|app|gg))+)]\((?:http://|https://)(?:\w+\.)+\w+(?:/\w+)*\)" & @CRLF & _
"" & @CRLF & _
"Since this compiles to a shorter resulting regex (add more subdomains after auth to catch more. )"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")