package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(https?|ftp):\/\/[a-z0-9-]+(?:\.[a-z0-9-]+)+(\/[\w-]+)*\/[\w-]+\.deb$`)
var str = `http://asdfasdf.hu/asdfasddebd/d`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}