package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\.ngfactory\.js|\.ngstyle\.js|\.ts)$`)
var str = `test.ts
test2.spec.ts
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}