$re = '/([a-zA-Z]+)\\\\\/$/m';
$str = 'https:\\/\\/s.something.com\\/target\\/{im}\\/hkqgwOSXcZ\\/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);