$re = '/(\W*\d+)*(?=\W|$)/m';
$str = '0000000000000000000000000000Abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);