$re = '/(?:\"[^\"]+\"|[^,]+)(?=,|$)/m';
$str = 'Data1, Data2 ,"Data 3, more", Data 4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);