$re = '/<div>.*<\/div>/m';
$str = '123<div>abc</div><span>DEF</span><div>ghi</div>456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);