$re = '/[+-]?\d+(\.\d+)+E[+-]?\d+/i';
$str = '1.23e+10
-4.56E-7
0e14';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);