re = /(?=\D*\d)[\w\/-]{7,}/m
str = 'Te poniższe bym chciał:
ZOC1050056
23639583
GL20/11878/17
20700246365_1
WR50/11349/17
PL201709120448
pl2017072600414
1054332/1133787
H201709201932-01
143392/DLS/17 KO/455/17
12222222/22
a to już false positives:
66565
bardzodlugieslowo
niechcetegoo?
2/zamalocyfer
32tubysietez przydalo wiecej'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end