$re = '/^[a-z\d]+(\-[a-z\d]+){0,7}$/m';
$str = 'zerox
wtech
001-game-creator
2d-fighter-maker-2nd
2d-rts-multiplayer-engine
2devolved
2dream
2moons
3d-engine-gepard
3d-rad
3dge
3dstate
3dvia-studio
3dzzd
3impact
4a-engine
9gears
adaptive-game-engine-age
adobe-director
adobe-flash-professional
advengen
adventure-game-studio
adventure-maker
affinity-engine
agar
age
age1
age-3d
agen
agharta-studio-engine
airnovel
akari3d-engine
alamo
aleph-one
alicesoft-system-40
allbinary-platform
altengine
ambrose3d
amp2
andengine
angry-turtle
anime-studio
annihilation-engine-for-source
antiryad-gx
scimitar
apexcmd
apocalyx
app-game-kit
apricotjs
aqua
archive-games
argon-4
articx
aspen
astrogame-engine
aura
aura-engine
aurora-engine
away3d
axis
axis-game-factory
aztica-6dx
babylonjs
backbone-game-engine
bacon2d
bang-engine
barok
barrage-engine
base-render-unit-engine
bennugd
biengine
big-world-technology
bit-engine
bitsquid
bittech
black-sun-engine
blackion-game-engine
blade3d
blanke
blast3d
blender-game-engine
blitwizard
blitz-max
blockygame-engine
bloxel
box2d
brahma
brender
brfactory
bright-engine
broken-mug-engine
btengine
build
build2
c3d
cafu-engine
calidus
cardboard-engine
carnivorous-exports
castle-game-engine
cellblock-9
cgda-computer-game-development-architecture
chrome-engine-1
chrome-engine-2
chrome-engine-3
chrome-engine-4
chrome-engine-5
chrome-engine-6
cine-engine
clausewitz-engine
cloacknt-engine
cloaknt
clockwork-engine
cloudbuilder
cmv-3d
cocos2d-for-iphone
cocos2d-x
collapsed-engine
colyseus
commandos-engine
concept-2d
construct
construct-2
construct-3
coppercube
core
corengine
corona
corrinoengine
cortex
corus-engine
corvus-engine
cosmic-engine
covertengine
cpal3d-engine
cr-editor
craftstudio
crazy-engine
creation-engine
crimson-engine
crowdcore-engine
crybits
cryengine
cryengine-2
cryengine-3
cryengine-v
crystal-dynamics-engine
crystalspace-3d
ctech-25d
cube
cube-2
cumulonimbus-engine
custom-built
cyclone-engine
daedalus
daemon
dagmen-engine
dagon
dagor
dark-engine
dark-tech
darkbasic-professional
darkplaces-engine
defold
demon-tactic-engine
diasphere
diesel-engine
digital-dream-engine
dim3-dimension-3
dingo-engine
directd3x-75
div-go-games-online
doom-engine
doom
dotnettorque
dotworldmaker
dragengine
dragans-games-inhouse-engine
dragonov3d
dragonsource
dragora-framework
dream-maker
dsk
duality
dungeons-3d
dunia
dust
dx-studio
e-kfuture-engine
epic
e2d-engine
easy3d
eclipse
eclipse-evolution
eclipse-origins
eclipse-skywyre-2d-orpg-maker
eduke32
ees
eg-3d-game-engine
egdk-engine
ego-game-technology-engine
eternallove-engine
electric
element-games-engine
emily-is-away
empowered-creation-kit
enginex
enigma-development-environment
enigma-engine
enin-engine
environ
epsilon
essence-engine
eternal-tech
ethanon
etna-2d-gameengine-net
europa-engine
ev-va-engine
existence-2
exotic-matter-engine
extreme-motion
ezengine
f2b-engine
fastbird-engine
fenix
fire-frost-2d
first-frost
first-flight
flashpunk
flashugee
flatredball
flax
fle-game-engine
fife
flight-deck-ge
flight-engine
flixel
flowlab
flux-engine
fonline-engine
forgelight-engine
fox-engine
foxhound-engine
fps-creator-x10
fpsc
free-heroes-of-might-and-magic-ii-resurrection
free-libre-action-roleplaying-engine
freebasic
frostbite
frostbite-2
frostbite-3
fs2-open-engine
fte-quakeworld
fusee
game-develop1
game-develop
game-development-suite
game-hammer-beta
game-pencil-engine
gamebryo
gamecake
gamecore-3d
gameguru
gamekumo
gameleon
gamemaker
gamemaker-studio-2
gameos
gameplay
gamepower-engine
gamesalad
3d-game-studio
gamestudio-a8
gamvas-web
geex-suite
gegameengine
gem-1
gem-2
gem-25-halo-mod
gem-3
gemix
genesis-game-engine
genesis3d
genie-engine
genome
geo-mod-2
gewiz-es
ggamee-engine
ggez
gibbo2d
gideros
glbasic
glest-engine
glow
glue-engine
godfather
godot-engine
goldsource
grtech1
grace
grace-2
greed-tech-mit
greeg-engine
greensrc
grey-source
grime
gsc-rts
haafs-game-engine
hailstorm
halo-engine
hard-truck-series-engine
harfang-3d
hat
haxeflixel
haxepunk
hedgehog-engine
hell-engine
hercules
heroengine
hex-engine
hiber
houdini
hpl
hpl2
hpl3
html5
hypatia-engine
i-novae-engine
ice-2d-game-engine
id-tech-2
id-tech-3
id-tech-4
id-tech-5
id-tech-6
ignite
immortal-engine
imod-touch
impact-js
imperial-game-engine-25
imperial-game-engine-2-the-black-throne
imperial-game-engine-31
imperium-engine
impossible-creatures-engine
impulse-engine
infernal-engine
infinity-engine
infinityengine
inovator2d1
insanity
instead
intersect-engine
ioquake3
iriszoom
iron-engine
irrlicht-3d-engine
irrlicht-engine
isdge
itorque2d
iw-engine
j4game
jade
jenesis-engine
jgame
jmonkeyengine
k2
kapow-systems-3d
kata-engine
na276
kinetica
kinjin
kirikiri2
kivy
kiwi-js
klik-play-engine
kochol-game-engine
kokusai-fighting-engine
kraken-engine
kurok-sdk
lacuna-engine
lambdahack
lance
leadwerks-engine
leaf-engine
lengine
libgdx
lightfall
lightweight-java-game-library
limetexte
limon-engine
liquid
lira-sdk-2016
lithtech
litiengine
love
ls3d
lua-player
lugdunon1
lumberyard
lumix-engine
lunar-development-kit
lux-engine
lyn
mugen
m484-game-creation-system
madness
maker3d
mandate-engine
maratisdel
maratis
marv-engine
masstech
medusa
megaglest-engine
meh-engine
melonjs
mercury
mercury-engine
methyl
mirage-legacy-2d-orpg-engine
moai
night-source
mojito
moltengl
monkey
monogame
motion-engine-2
multimedia-fusion
multiverse-engine
naos
ncine
ndemic-engine
nemesis-engine
neoaxis-3d-engine
ness-engine
newgrounds-3d
ngunix
nitrous
node-webkit
no-nonsense
notsogoodengine
novalis
novashell-game-creation-system
novelty
nuclear-engine
nyx-engine
o3de
obelisk
odyssey
oengine
official-hamster-republic-rpg-creation-engine
ogier
ogre-engine
ogs
oldschool-library
oni-engine
open-game-engine
opengine
openmw
openspace3d
orx
outerra
outerra-engine
ouzel
owengine
panda3d
paradigm-engine
paradox
paradox-2
pathengine
pathway2d
peak-one-engine
pentah
perfect-dark-engine
pfr-game-engine
phaser
phoenix-engine
phoenix-engine-relic-entertainment
phoenix3d
photon-cloud
phyreengine
pi-engine
pineapple
pipengine
pipengine-2d
platform-games-editor
platinum-arts-sandbox-free-3d-game-maker
play-street-engine
playcanvas
playir
polygon-engine
popcap-games-framework
power-3d-engine-1x
project-anarchy
project-angels
proland
prospekt-source
proxy-engine
pt2-engines
pyrogenesis
qae-framework
qfusion
qsm
quad-engine
quadrion-engine
quake-engine
quasar
quel-solaar
quest3d
quine-engine
r-cube-engine
r13bge-r13b-game-engine
rage
raycasting-game-maker
raylib
rayne
rc-basic
rcce2
real-virtuality
real-virtuality-2
real-virtuality-3
real-virtuality-4
reality-factory
realm-crafter
redkit
redsky-engine
refractor
refractor-2
renpy
renderware
retox
retribution
retroquad
rfs2-engine
rigidlight-tech
rng-roguelike-sdk
rockhard-engine
root
root-framework
rosalila-shooter-engine
rpginabox
rpg-maker-2003
rpg-maker-mv
rpg-maker-mz
rpg-maker-vx
rpg-maker-vx-ace
rpg-maker-xp
rpgboss
run3-game-engine
ryzom-core
s-ogl
s2engine-hd
s3d-engine
sage-strategy-action-game-engine
samone
scape
schmetterling
scummvm
sebbels-mmorpg-bastler
serious-engine
sfml
shatter
shiva3d-19
shmup-creator
shoot-em-up-kit
silk
silver-arc
silverlight
silvershineengine
simmetri
simulator-reality
simvox
sio2-interactive
sith-engine
sizzler-engine
skybolt
skyline-game-engine
slayer
slick-2d-slick-ae
slip-frag
sludge
sly-ngine
smile-game-builder
smilebasic
sommerwind
source
source-2
space-virtual-world
spark
spark-sdk
sphere-game-engine
spiral-engine
spooker-framework
spring
spritekit
square-engine-plus
squeeze-bomb
ss-sdk
starflare-engine
starling
stencyl
stingray
storm-engine-2-working-title
storm3d
story-game-creator
stratagus
sugarbombengine
super-smash-flash-2-engine
superscroller
synapse-engine
syntensity
tac-sys
tadpole-treble
tak-runtime
techengine
telejano
tes3mp
tesseract-engine
the-3d-gamemaker
the-chiller-engine
the-dawn-engine
the-exist
explorerengine
the-fsengine
the-glaze-package
the-mana-world
the-manchu-cross-engine
tilemapkit
tilengine
tiles-engine
tilesense
tiny2d
titan
esenthel-engine
titan-engine
toi-engine
tomb-raider-level-editor
topaz
torque-2d
torque-3d
torque-game-engine
torque-game-engine-advanced
torque-x
traktor
treyarch-ngl
tri-engine
triodim-engine
triplea
trivial-engine
truevision3d
tux
twine
tyranobuilder
ultra-app-kit
ut-engine
unigine
unity
unityagk-action-game-kit
universal-fighting-engine
unknown
unreal-development-kit
unreal-engine-1
unreal-engine-2
unreal-engine-3
unreal-engine-4
unreal-engine-5
upbge
urho3d
v-engine
v-play
valkyrie-engine
vassal
vcmi
vector-based-lines-engine-2d
venom-platformer-engine-v30
vereengine
vertical-leap
vide
virtua-form
vision-8
visionaire-studio
visual-novel-engine
visual3d-game-engine
vital-engine-3
vixle
void-engine
volatile-engine
vorb
voxel-space-2
voxeliq
voxel-rage-engine
vrender
vsgfx
vulkan4d
wade-game-engine
war-zombie-mmo
water-bubble
wave-engine
westwood-2d
white-rabbit-engine
wicked-engine
wimi5
wintermute
wolf-rpg-editor
wolf3d-engine
worldaxis-3d
worldforge-project
wurfelengine
x-framework2
x-ray-engine
xash3d-engine
xash3d-fwgs-engine
xcylin-engine
xemplar-2d-game-engine-ae
xenko
xeno3d-20
xenon-core
xero-engine
xi-cast-engine
xl-engine
xna
xngine
xni
xoreos
xors3d
xtremeworlds1
yeyhay-logic-engine
yeyhay-platform-engine
yin
ymir
zamn-engine
zdoom
zengin
zero-engine
zerofps
zgameeditor
zillex-games
zodiac-engine
zweide
zzt-oop';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);