using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"&G3FRM\.GetRecord\(""(?!PAGEREC\b)\w+""\)\.GetField\(""\w+""\)\.Value";
string input = @"&G3FRM.GetRecord(""PAGEREC"").GetField(""GSHOURS"").Value
&G3FRM.GetRecord(""RSCH_SETUP"").GetField(""Y_NIH_MNTHLY_CAP"").Value
&G3FRM.GetRecord(""PAYMENT"").GetField(""Y_HRS_TOTAL"").Value";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}