$re = '/(?<=@)\w+/';
$str = '@This is what I want to extract
@Jack @Marie Hi there!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);