import Foundation
let pattern = ##"(?!.?@.+)\s[\w\,\.\!\'\(\)\#]+"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
“@united: @Addair We hope you don't miss your connection. For help with re-Flight Booking Problems please Follow us & DM your confirmation. ^CPâ€done thx
=@united never fails to have delayed flights 😡
=@united I sent my details to the customer care link you sent me Almost a month ago and no response.
@united Hate when I get bumped out of the seat I've selected (& empty row) and moved to another seat (non-empty). #1K #flt803 #nonupgrade!
Meanwhile, they fucked my flight. @united: The festivities are already in full swing at the United Fairway Club, overlooking the 17th hole..
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)