$re = '/(?:^|\|)(")?\K(.*?)(?=\1(?:$|\|))/m';
$str = '"1"|"Text"|"a"
"2"|""Text in quotes""|"ab"
"3"|"Text "around" quotes"|"abc"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);