$re = '/((?<=NA - FY\d\d .....)|(?<=NA - FY\d\d ....))[(](?!([^)]*\b(ARR)\b[^(]*)).*?[)]/';
$str = 'NA - FY17 JCIG (Joint Coord Integration Grp) briefs
NA - FY17 JIPT (Joint Integr Product Tm) briefs
NA - FY17 PP (Phasing Plans)
NA - POM 17\\NA - FY17 SoW (Statement of Work)
NA - FY17 SRRB (Serv Requi Review Brd) Quad chart
NA - FY17 UFR (Unfunded Plan) - CYD (Current Year)
NA - POM 17\\NA - FY17 DR (Directors Reviews) briefs"
NA - FY17 Funding Docs"';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;