re = /<table(?:(?!<\/?table>).)+?Время.+?<\/table>/i
str = '<p>Текст</p>
<table>
<tr>
<td>разные данные</td>
</tr>
</table>
<table>
<tr>
<td>Режим</td>
</tr>
<tr>
<td>Тратата</td>
</tr>
</table>
<p>Текст</p>
<table>
<tr>
<td>Время</td>
</tr>
<tr>
<td>Тратата</td>
</tr>
</table>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end