re = /INICIO.*?FIM/m
str = 'JJJJJJJJJJJJJJJINICIOAAAAAAAAAAAAINICIOBBBBBBBBBBBBFIMJJJJJJJJJJJJJJINICIOJJJJJJJJJJJJJJFIM'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end