# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?'group1'[\d])"
test_str = ("101011010\n"
"110101101\n"
"111010110\n"
"111101011\n"
"011110101\n"
"101111010\n"
"110111101\n"
"011011110\n"
"001101111\n"
"100110111\n"
"110011011\n"
"111001101\n"
"111100110\n"
"011110011\n"
"001111001\n"
"100111100\n"
"010011110\n"
"001001111\n"
"100100111\n"
"010010011\n"
"001001001\n"
"000100100\n"
"000010010\n"
"000001001\n"
"000000100\n"
"000000010\n"
"100000001")
subst = "$1 & "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.