import Foundation
let pattern = #"edit(?:(?!edit)[\s\S])*?service ("ALL")[\s\S]*?next"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
edit 1035
set schedule "always"
set service "ALL2"
set utm-status enable
next
edit 103
set schedule "always"
set service "ALL"
set utm-status enable
next
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)