using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^\h*edit \d+(?:(?!^\h*edit)[\s\S])*?service (""ALL"")[\s\S]*?\R\h*next$";
string input = @" edit 1035
set schedule ""always""
set service ""ALL2""
set utm-status enable
next
edit 103
set schedule ""always""
set service ""ALL""
set utm-status enable
next";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}