$re = '/^(?:[^v]|v(?!a)|va(?!l)|val(?!u)|valu(?!e)|value(?!=))*value=(\S+)((?:[^v]|v(?!a)|va(?!l)|val(?!u)|valu(?!e)|value(?!=))*value=(\1))*(?:[^v]|v(?!a)|va(?!l)|val(?!u)|valu(?!e)|value(?!=))*$/m';
$str = 'aaaaaaa bbbbb value=cat cccccc ddddd value=cat fffffff value=cat ggggg hh jjj value=cat kkkkk
aaaaaaa bbbbb value=bat cccccc ddddd value=bat fffffff value=bat ggggg hh jjj value=bat kkkkk
aaaaaaa bbbbb value=cat cccccc ddddd value=cat fffffff value=rat ggggg hh jjj value=cat kkkkk';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);