$re = '/(?:\/en)*(\/.+)$/m';
$str = '.com/en/testing.aspx
.com/testing.aspx
.com/en/testing.aspx
.com/option/en/sub1/sub2/testing.aspx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);