const regex = /\w{31,}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\w{31,}', 'gm')
const str = `astringsmaller alongstringthatisgreaterthan32characterstomatch
alongstringthatisgreaterthan32characterstomatch astringsmaller
astring string alongstringthatisgreaterthan32 598931
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}