using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\S)\d(?!\S)";
string input = @"3 people, 20 hours, 33 chairs, 11 minutes, 4 days, 5.50€, 3 instances, 7 miles";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}