import Foundation
let pattern = #"(?:([\/≈↓£°!↑]).*?\1|\([^()]*\)|<[^<>]*>)(*SKIP)(*F)|\s+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
↑hey girls↑ can I <join yo:u>
((v: grunts))
!damn shit! got it
I mean /yeah we saw each other at a party:/↓ the other day
↑!THAT'S! A WOMAN !THAT'S! A WOMAN↑
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)