$re = '/<[\w]+>([\w]+)<\/[\w]+>/m';
$str = '<p align="center"><font size="6" color="#FFFF00"><u><strong>Weapons</strong></u></font></p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);