import re
regex = re.compile(r"input")
test_str = ("901010-1010101\n"
"910212-1101011\n"
"891010-9876543\n"
"830301-1*14313\n"
"9611112035555\n"
"961213-2345678\n"
"020202-4321012")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")