$re = '/(Move\s[0123456789]\s)+(Left\s)(Right\s)/m';
$str = 'Move 1 Move 2 Left Right ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);