import re
regex = re.compile(r"Reg: Email:", flags=re.MULTILINE)
test_str = ("Hi,\n"
"Congrats, your offer on a Ford Ka for the price of £2,000.00, was the winning offer!\n"
" \n"
"Car Details\n"
" Ford Ka \n"
"Model: Ford Ka\n"
"Reg: LN61XVW\n"
"Fee: £229.0\n"
"Distance: 32 miles\n"
"Mileage: 28709\n"
"Car age: 13\n"
"Colour: BLACK\n"
"See customer details\n\n"
"You’ll need to find a time that’s right for both parties so you can inspect the vehicle and make sure it looks as good as advertised.\n\n"
"Ask us to collect for you or pick it up yourself and arrange payment with the seller.\n"
" \n"
"Customer Contact Details\n"
" \n"
"Name: Donna Irwin\n"
"Phone: +447884015643\n"
"Email: donna.irwin@btinternet.com\n"
"Postcode: AL1 2ET\n"
" \n"
"Follow the link below to get in touch and exchange details.\n"
"Contact the seller here\n"
"Use the help link below if you have any questions.\n"
" \n"
" \n"
"Happy Hunting,\n"
"The Carwow Team")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")