$re = '/(\d{6})(\d{6})(\d{4})/m';
$str = '3456902345871092';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);