import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?si)\\A\\s*(?:(<!--.*?-->|<!DOCTYPE\\s+svg([\\s:]+.*?>|>))\\s*)*<svg[\\s>\\/]";
final String string = "<!-- test -->\n\n"
+ "some <p></p> html tags, this svg file is not valid\n\n"
+ "also, look after </svg> ends\n\n"
+ " <!-- prettier-ignore -->\n"
+ " <svg xmlns=\"http://www.w3.org/2000/svg\" width=\"10\" height=\"10\" viewBox=\"0 0 10 10\">\n"
+ " <path fill=\"#8E8E93\" fill-rule=\"evenodd\" d=\"M9.816 8.981L7.08 6.243c.49-.67.753-1.479.75-2.309C7.819 1.767 6.067.013 3.9 0 2.864-.005 1.868.406 1.135 1.14.403 1.872-.006 2.868 0 3.905.01 6.072 1.762 7.828 3.93 7.84c.833.004 1.645-.262 2.315-.758l.003-.002 2.735 2.736c.148.156.368.218.576.165.207-.054.37-.216.423-.424.054-.207-.01-.428-.165-.576zm-5.89-1.925C2.193 7.046.79 5.642.783 3.909c-.005-.83.322-1.626.908-2.213.586-.587 1.383-.915 2.212-.912 1.733.01 3.135 1.414 3.143 3.147.004.83-.323 1.626-.909 2.213-.586.587-1.382.915-2.211.912z\"/>\n"
+ " </svg>\n"
+ " <svg xmlns=\"http://www.w3.org/2000/svg\" width=\"10\" height=\"10\" viewBox=\"0 0 10 10\"><path fill=\"#8E8E93\" fill-rule=\"evenodd\" d=\"M9.816 8.981L7.08 6.243c.49-.67.753-1.479.75-2.309C7.819 1.767 6.067.013 3.9 0 2.864-.005 1.868.406 1.135 1.14.403 1.872-.006 2.868 0 3.905.01 6.072 1.762 7.828 3.93 7.84c.833.004 1.645-.262 2.315-.758l.003-.002 2.735 2.736c.148.156.368.218.576.165.207-.054.37-.216.423-.424.054-.207-.01-.428-.165-.576zm-5.89-1.925C2.193 7.046.79 5.642.783 3.909c-.005-.83.322-1.626.908-2.213.586-.587 1.383-.915 2.212-.912 1.733.01 3.135 1.414 3.143 3.147.004.83-.323 1.626-.909 2.213-.586.587-1.382.915-2.211.912z\"/></svg>\n"
+ " </div>\n\n"
+ " <button class=\"product-list-filter__reset\" type=\"button\">\n"
+ "@ -49,9 +50,10 @@\n"
+ " <div class=\"product-list-filter__scrollable\">\n"
+ " <div class=\"js-namings-autocomplete-matched\">\n"
+ " @foreach ($filter_namings->sortBy('display_name') as $naming)\n"
+ " @continue($search_namings->contains('display_name', $naming->display_name))\n"
+ " <div class=\"spoiler__item\">\n"
+ " <label tabindex=\"0\">\n"
+ " <input type=\"checkbox\" value=\"{{ $naming->id }}\" {{ $search_namings->contains($naming->display_name) ? 'data-checked=\"true\"' : 'data-checked=\"false\"' }}>\n"
+ " <input type=\"checkbox\" value=\"{{ $naming->id }}\" {!! $search_namings->contains('display_name', $naming->display_name) ? 'data-checked=\"true\"' : 'data-checked=\"false\"' !!}>\n"
+ " <span>{{ $naming->display_name }}</span>\n"
+ " </label>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}