$re = '/(?:[A-Z][a-z]|[a-z][A-Z])*/m';
$str = 'AbAb
aBaB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);