#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\v)nate"
Local $sString = "line one⋮" & @CRLF & _
"line twoimport { CustomCacheKey } from '@layer0/core/router'" & @CRLF & _
"" & @CRLF & _
"router.get('/some/path', ({ cache }) => {" & @CRLF & _
"" & @CRLF & _
" cache({" & @CRLF & _
"" & @CRLF & _
" key: new CustomCacheKey().addCookie('language').addCookie('currency')," & @CRLF & _
"" & @CRLF & _
" // Other options..." & @CRLF & _
"" & @CRLF & _
" })" & @CRLF & _
"" & @CRLF & _
"})import { CustomCacheKey } from '@layer0/core/router'" & @CRLF & _
"" & @CRLF & _
"router.get('/some/path', ({ cache }) => {" & @CRLF & _
"" & @CRLF & _
" cache({" & @CRLF & _
"" & @CRLF & _
" browser: {" & @CRLF & _
"" & @CRLF & _
" // Sets the cache-control: maxage=n header sent to the browser. To prevent the browser from caching this route" & @CRLF & _
"" & @CRLF & _
" // set maxAgeSeconds: 0" & @CRLF & _
"" & @CRLF & _
" maxAgeSeconds: 0," & @CRLF & _
"" & @CRLF & _
" // Sends a non-standard header `x-sw-cache-control: n` that you can use to control caching your service worker." & @CRLF & _
"" & @CRLF & _
" // Note that service workers do not understand this header by default, so you would need to add code to your service" & @CRLF & _
"" & @CRLF & _
" // worker to support it" & @CRLF & _
"" & @CRLF & _
" serviceWorkerSeconds: 60 * 60," & @CRLF & _
"" & @CRLF & _
" }," & @CRLF & _
"" & @CRLF & _
" edge: {" & @CRLF & _
"" & @CRLF & _
" // Sets the TTL for a response in Layer0's edge cache" & @CRLF & _
"" & @CRLF & _
" maxAgeSeconds: 60 * 60 * 24," & @CRLF & _
"" & @CRLF & _
" // Sets the amount of time a stale response will be served from the cache. When a stale response is sent, Layer0" & @CRLF & _
"" & @CRLF & _
" // will simultaneously fetch a new response to serve subsequent requests." & @CRLF & _
"" & @CRLF & _
" // Using stale-while-revalidate helps raise your effective cache hit rate to near 100%." & @CRLF & _
"" & @CRLF & _
" staleWhileRevalidateSeconds: 60 * 60, // serve stale responses for up to 1 hour while fetching a new response" & @CRLF & _
"" & @CRLF & _
" // And many other options" & @CRLF & _
"" & @CRLF & _
" }," & @CRLF & _
"" & @CRLF & _
" // Optionally customizes the cache key for both edge and browser" & @CRLF & _
"" & @CRLF & _
" key: new CustomCacheKey()" & @CRLF & _
"" & @CRLF & _
" .addBrowser() // Split cache by browser type" & @CRLF & _
"" & @CRLF & _
" .addCookie('some-cookie'), // Split cache by some-cookie cookie" & @CRLF & _
"" & @CRLF & _
" })" & @CRLF & _
"" & @CRLF & _
"})router.get('/scripts/:file', ({ serveStatic }) => {" & @CRLF & _
"" & @CRLF & _
" serveStatic('path/to/scripts', {" & @CRLF & _
"" & @CRLF & _
" permanent: true, // ensure that files are permanently accessible, even after a new version of the site has been deployed." & @CRLF & _
"" & @CRLF & _
" exclude: ['some-non-versioned-file.js'], // you can exclude specific files from being served permanently. You should do this for any files that do not have a hash of the content in the name." & @CRLF & _
"" & @CRLF & _
" })" & @CRLF & _
"" & @CRLF & _
"})"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")