re = /^(?=\w{6,10}$)(?=[^a-z]*[a-z])(?=(?:[^A-Z]*[A-Z]){3})(?=\D*\d)\D*\d*/
str = 'AbcDeF1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end