$re = '/(?<=CI_ID:)(.*?)(?=$|\z|,)/m';
$str = 'Country:Corporate, Role:Application, Application:Magic Bonus, CI_ID:xxx000555x76ad98325lkafd8, AppEnvironment:Gama, Region:Global';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);