re = /^(?=[a-zA-Z]{7}$)(.)(?!\1)(.)(?!\1)(?!\2)(.)\2(?!\1)(?!\2)(?!\3).\2\1$/m
str = 'abcbdba
aaaaaaa
abcdefg
abababa
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end