import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[*]{30})([^*][\\x29\\{,10\\}|\\u00c0-\\u00d6|\\u00d8-\\u00f6|\\u00f8-\\u02af|\\u1d00-\\u1d25|\\u1d62-\\u1d65|\\u1d6b-\\u1d77|\\u1d79-\\u1d9a|\\u1e00-\\u1eff|\\u2090-\\u2094|\\u2184-\\u2184|\\u2488-\\u2490|\\u271d-\\u271d|\\u2c60-\\u2c7c|\\u2c7e-\\u2c7f|\\ua722-\\ua76f|\\ua771-\\ua787|\\ua78b-\\ua78c|\\ua7fb-\\ua7ff|\\ufb00-\\ufb06|\\x20-\\x2A|\\x2B-\\x7E]+[^*])(?=[*]{15,})";
final String string = "ÿÿÿÿ*************************************************CURRICULUM VITAE***Información *personal*********************ìÌ**Ì*Ì*Ì*\n"
+ "ÿùpùpùùuyruytuythghgjjghjjgjghÿÿÿ***************************************************CURRICULUM VITAE***Información *personal****************************************************ìÌ**Ì*Ì*Ì*\n"
+ "ÿùpÿÿ***************************************************CURRICULUM VITAE***Información *personal**************ìÌ**Ì*Ì*Ì*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}