#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " ?\b\d+\b ?"
Local $sString = "0 I64 EB MM 93" & @CRLF & _
"1519 KINGSCROSS RD" & @CRLF & _
"28 VA288 298" & @CRLF & _
"JOHN RANDOLPH RD" & @CRLF & _
"4700 WALMSLEY BL" & @CRLF & _
"BOWLING GREEN RD / BOB WHITE RD" & @CRLF & _
"BRUCE CT /FLORIDA AV" & @CRLF & _
"BUCK RD AND WHITEHALL RD" & @CRLF & _
"DOWNTOWN EWRESSWY EB 2ND ST" & @CRLF & _
"HYHLAND VISTA / GEORGE WASHINGTON BL" & @CRLF & _
"HYHLAND VISTA / GEORGE WASHINGTON BL" & @CRLF & _
"HYHLAND VISTA DR / GEORGE WASHINGTON BL" & @CRLF & _
"I95 25 43" & @CRLF & _
"LAUARL RIDGE MILL RD /CLARENCE RD" & @CRLF & _
"LAUARL RIDGE MILL RD /CLARENCE RD" & @CRLF & _
"NOVAH HOWARD ST /SEMINARY RD" & @CRLF & _
"OLD COUVAHOUSE RD R COUVAHOUSE RD" & @CRLF & _
"OLD COUVAHOUSE RD R COUVAHOUSE RD" & @CRLF & _
"WOODLAND AND ROANOKE" & @CRLF & _
"1501 SAMS CR1" & @CRLF & _
"15281 WHITEHEAD RD" & @CRLF & _
"1532 MARLBORO ST" & @CRLF & _
"16907 BRANDERS BRIDGE RD" & @CRLF & _
"1750 WILLIAM ST "
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)