#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d{1,2}\S\d{3})"
Local $sString = "<table style="width: 440px; margin: 10px auto; background-color: #CCC; text-align: center; border-spacing: 1px;"><tbody><tr style="background-color: #FFF;"><td rowspan="2"> </td><td colspan="2" style="padding: 3px;"> </td><td colspan="2" style="padding: 3px; background-color: #E8E8E8;"></td></tr><tr style="background-color: #FFF;"><td style="padding: 3px;"></td><td style="padding: 3px;"></td><td style="padding: 3px; background-color: #E8E8E8;">Час</td><td style="padding: 3px; background-color: #E8E8E8;"></td></tr><tr style="background-color: #FFF;"><td style="padding: 3px;"></td><td class="ver12 nowrap" style="padding: 3px;"><b>8 000 р.</b></td><td class="ver12 nowrap" style="padding: 3px;"><b>16 000 р.</b></td><td class="ver12 nowrap" style="padding: 3px; background-color: #E8E8E8;"><b>10 000 р.</b></td><td class="ver12 nowrap" style="padding: 3px; background-color: #E8E8E8;"><b>60 000 р.</b></td></tr><tr style="background-color: #FFF;"><td rowspan="2" style="padding: 3px;">*</td><td class="ver12 nowrap" style="padding: 3px;"><b>-</b></td><td class="ver12 nowrap" style="padding: 3px;"><b>25 000 р.</b></td><td class="ver12 nowrap" style="padding: 3px; background-color: #E8E8E8;"><b>25 000 р.</b></td><td class="ver12 nowrap" style="padding: 3px; background-color: #E8E8E8;"><b>70 000 р.</b></td></tr><tr style="background-color: #FFF;"><td colspan="4" style="padding: 3px;"></td></tr><tr class="noprint" style="background-color: #FFF;"><td colspan="3" rowspan="2" style="text-align: left;"><div style="margin: 5px 7px;"></div><div style="margin: 5px 7px;"><a href="#" onclick="return helpContacts();"><img src="I/question.gif" border="0" width="11" height="11" alt="" style="vertical-align: text-bottom;" onmouseover="this.src='I/question.png';" onmouseout="this.src='I/question.gif';" /></a></div></td><td style="padding: 3px;"></td><td class="ver12 nowrap" style="padding: 3px;"><b>-</b></td></tr><tr class="noprint" style="background-color: #FFF;"><td style="padding: 3px;"></td><td class="ver12 nowrap" style="padding: 3px;"><b>-</b></td></tr><tr class="noprint" style="background-color: #FFF;"><td colspan="5" class="ar13" style="padding: 5px 7px; text-align: left;"><i></i></td></tr></tbody></table>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")