package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"([^"]+)"|\s+`)
var str = `te s s sdg gdg sdg "gh hh"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}