package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)H\S*I\S*Y`)
var str = `HOLIDAY`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}