$re = '/^[a-zA-Z0-9]+?\.?[a-zA-Z0-9]+?\*?$|^\*$/m';
$str = 'test.test
test.test*
*
.
_
test.*
test.test
test.test2
test*
te*st
test*.test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);