re = /^\s*(([+]?(0|[1-9][0-9]*)([Ee][+]?[0-9]+)?\s+){2}[+]?[0-4](\s+(0x[0-9a-fA-F]{1,16}|[+]?(0|[1-9][0-9]*)([Ee][+]?[0-9]+)?))*\s*,?\s*)*$/m
str = ' 0 0 0 123 4 0xab , 0 0 0 123 4 0xab ,'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end