$re = '/^([a-z0-9]{1,}).*(\1)$/um';
$str = '123123123123
daddaddaddad
sadsadasad
sadsadsad
121212121
sasasasasas
sdsdsdsds
dsdsdsdsd
ffffffff
blahblah
ioiooioioioi
popopopopop
ooooo
ooo
iiii
Hi I dont think this is a spam.
II loooovve this. It\'s awesooooommeee!
omggg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);