# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:^|, )\d+(?!/)"
test_str = ("1John Radcliffe Hospital/Oxford/United Kingdom, 11Ruhr-Universität \n"
"3/Bochum/Bochum/Germany, 3University of British Columbia/Vancouver/Canada, 4National \n"
"Institute of Neuroscience, National Center of Neurology and Psychiatry/Tokyo/Japan, \n"
"5University of Catania/Catania/Italy, 6F. Hoffmann-La Roche Ltd/Basel/Switzerland, 7 \n"
"University of Colorado School of Medicine/Aurora/United States of America")
subst = "\\g<0>="
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.