$re = '/<([a-z]+)(?=[\s>])(?:[^>=]|=\'[^\']*\'|="[^"]*"|=[^\'"\s]*)*\s?\/?>/mi';
$str = '<html> <head> </head> <body> <a>This is a tagt 2</a> <p>This is paragraph1</p> <a>This is Assigntment 2</a> <p>This is paragraph1</p> <div> <img> </img> </div> <body> </html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);