re = /^(?=(?!(.)\1)([^\DO:105-93+30])(?-1)(?<!\d(?<=(?![5-90-3])\d))).[^\WHY?]$/
str = '42'
# Print the match result
str.match(re) do |match|
puts match.to_s
end